最新Eclipse中Javadoc配置教程

未分类 , , , , 发表评论
最新Eclipse中Javadoc(JDK7)详细配置信息: 1、打开Eclipse——>Windows——>Preferences; 2. 在弹出的Preferences对话框中,Java——>Installed JRES——>选中jre(根据自己的安装确定)——>Edit; 3. 在弹出的 Edit JRE对话框中,选中你JRE安装路径下的lib\rt.jar,这之后会弹出两项:Source attachment和Javadoc location。 4. 点击Source attachment,会发现按钮“Source attachment”可用,然…

oracle11g em按钮乱码问题

未分类 , , , , 发表评论
#在$JAVA_HOME/jre/lib/fonts/下建一个fallback目录,把你想在java中使用的字体复制到这个目录中即可,在oracle用户下:$ mkdir $ORACLE_HOME/jdk/jre/lib/fonts/fallback把windows下的字体文件simsun.ttc复制到$ORACLE_HOME/jdk/jre/lib/fonts/fallback目录下并改名simsun.ttf(注意ms的simsun字体是有版权的,所以商用换其他字体),相应的权限改为oracle用户可用.之后需要清理一下Cache,重启EM即可:$ …

jvm(转帖)

未分类 , , , , 发表评论
http://dev.csdn.net/article/32/32926.shtm jdk(java development kit),jre(java run-time environment),jvm(java virtual machine) 有两套jre在你的电脑中,为什么一台pc要有两套jre呢?那是因为我们所用到的jdk里面的包括javac.exe,java.exe等等工具实际上也是用java开发出来的,因此我们必须要在安装jdk的同时安装jre,不然你的jdk中的工具将会无法使用,而在C:\Program file\java中的jre…

正式开始学习java

未分类 , , , , , 发表评论
没想到搞定“hello  world”也会出现问题,遇到的问题是提示: “Exception in thread "main" java.lang.UnsupportedClassVersionError” 原来是环境变量设置的问题,不是没有设置,而是因为有多个版本,但没有将需要用到的版本放在最前面。 windows本身,或者oracle等都会带有jre,这些jre通常不是所用的jre,看path中就可以看到。需要将所用版本的path放置在最前。需要重新启动来使设置生效。搜索java.e…

IIS + ServletExec ISAPI组合安装arcIMS4.0。

未分类 , , , , , 发表评论
IIS + ServletExec ISAPI组合安装arcIMS4.0。 软件要求: ArcIMS 4.0  Windows IIS 5.0  ServletExec API 4.0  Java SDK1.4.2 or Java JRE 1.4.2 软件下载: 在arcIMS的安装盘上,自带了ServletExec软件和Java JRE运行环境。分别在安装目录的ServletExec文件夹下和support/JRE文件夹下,ArcIMS自带的JRE是1.4.0版本如果需要得到最新的JRE,连接网址下载。要得到最新的ServletExec软件,连接网址 Servl…

[Java基础]Linux/Ubuntu安装JDK和配置环境

未分类 , , , , 发表评论
Java开发人员只要安装JDK即可,不需要特地安装JRE,JDK已经包含JRE了。 PS:如果您不是开发人员,而只是需要使用基于Java的产品,那么安装JRE即可,JRE不提供Develop Kit,JRE只提供运行命令java,没有编译命令javac等。   安装(安装JDK): (1)下载JDK:写此文时最新是Java SE Development Kit 6u23,来自Oracle官网 。 或: wget http://cds.sun.com/is-bin/INTERSHOP.enfinity/WFS/CDS-CDS_Develope…

xmpp with openfire之二 openfire安装

windows下的安装1.首先到[url]http://www.igniterealtime.org/projects/openfire/index.jsp[/url]下载最新安装包*注意有包含JRE版本和不包含JRE版本,不含JRE版本需要 JRE 1.5.0及以上的支持2.安装或解压完毕,启动bin目录中的openfire.exe*如果希望将openfirep添加到服务中还可以使用以下命令:openfire-service /install -- 安装服务openfire-service /uninstall -- 卸载服务openfire-service /start…

在SUSE Linux上安装oracle 9时,dbca 出错的解决办法

问题描述:在命令行执行dbca,启动不起来,出现:$JRE_DIR/bin/jre -DORACLE_HOME=$OH -DJDBC_PROTOCOL=thin -mx64m -classpath $CLASSPATH oracle.sysman.assistants.dbca.Dbca $ARGUMENTS等错误初步判断是和JRE有关系    应该是JRE 的版本不对。oracle 的dbca脚本里默认的JRE 是 1.1.8   1. rm $ORACLE_HOME/JRE (此JRE链接是1.1.8 的符号链接,需要改指向向1.3.1的)   2. ln -s $ORACLE_BASE/jre/1.…

Network Workbench Tool安装与Oracle10g中的jre版本问题

未分类 , , , 发表评论
安装Network Workbench Tool(nwb),下载[url]nwb-installer-1.0.0-beta5-win32.win32.jar[/url],通过命令行执行安装,命令为 java -jar G:\nwb-installer-1.0.0-beta5-win32.win32.jar,不过遇到问题不能进行安装。我试图将nwb-installer-1.0.0-beta5-win32.win32.jar导入到eclipse中,可以正常安装,eclipse中的jre是1.6.0版本。我记得自己的机器上jre是1.6.0,感到奇怪。通过命令行java -version察…

jdbc

sql server[url=http://msdn.microsoft.com/data/jdbc]microsoft[/url]sqljdbc4.jar for JDBC 4.0 API need JRE 6sqljdbc.jar for JDBC 3.0 API need JRE 5 (on JRE 6 will throw an exception when connecting to a database)[url=http://sourceforge.net/projects/jtds/files/]jtds[/url](可以用于oracle sql developer)jtds-1.2.4.jar for JDBC 3.0 API

ubuntu下oracle10g EM 显示乱码正确的解决办法 口口

未分类 , , , , , 发表评论
网上通用的解决办法:   修改jdk 下面的字体。 $ cd $ORACLE_HOME/jdk/jre/lib/ $ mv font.properties font.properties_bak $ cp font.properties.zh_CN.Redhat font.properties 修改jre 下面的字体 $ cd $ORACLE_HOME/jre/1.4.2/lib $ mv font.properties font.properties_bak $ cp font.properties.zh_CN.Redhat font.properties 清除em的cache $ rm -rf /home/oracle/ora10/oc4j/j2ee/oc4j_applica…

Linux中安装Oracle乱码问题的解决

在Linux中Oracle安装出现的乱码主要原因来自于oracle自带的jre,所以我们首先安装自己的java的jre安装好后 ./runInstaller -jreLoc /usr/lib/jvm/java-1.5.0-sun-1.5.0.06/jre(改变为自己的jre路径) 其中红色部分改为你自己安装jre的路径。然后再试试是否一切都已恢复正常?至少我的没有问题了。

EM乱码

#停止EM emctl stop dbconsole isqlplusctl stop #进入$ORACLE_HOME/jdk/jre/lib目录 cd $ORACLE_HOME/jdk/jre/lib cp font.properties.zh_CN.Redhat font.properties #进入$ORACLE_HOME/jre/1.4.2/lib/目录 cd $ORACLE_HOME/jre/1.4.2/lib/ cp font.properties.zh_CN.Redhat font.properties #安装包 rpm -ivh ttfonts-zh_CN-2.14-6.noarch.rpm #进入$ORACLE_HOME/oc4j/j2ee/oc4j_applications/appli…

暂存路径缺失jre

         今天给客户远程在Windows2003 SP2上安装Oracle10.2.0报"暂存路径缺失jre"(报错参考如下图),找了一圈,知道怎么解决啦。   参考解决方法:              打开: 我的电脑——>属性——>高级——>环境变量——>Administrator的用户变量              将TEMP和TMP的值直接分别修改为C:\Temp和C:\Tmp,再启动安装,哦了。 原因分析:系统默认用户的TEMP和TMP变量忒长了,Oracle大哥找不到…

安装Oracle9i导致JRE版本错误

安装Oracle9I后,系统变量path中被加入:C:/Program Files/Oracle/jre/1.3.1/bin;C:/Program Files/Oracle/jre/1.1.8/bin;这两个路径将导致在命令行中编译java文件时使用1.3的JDK版本java -version将显示1.3,不管你的JDK实际上是多少并且javac命令不能使用删除这两个路径之后,问题解决