Bad version number in .class file

java.lang.UnsupportedClassVersionError: Bad version number in .class file

这是java的编译的版本问题,把版本改成一致的就可以了,例如jdk 和jre都设为6.0。

在myeclipse的配置信息里,就分别指它的编译级别(complier)和java运行环境(install jre).

web工程重启tomcat后,这个错误仍然存在。

把tomat使用的jdk也改过来,重新部署,重新启动tomcat,就没问题了

[img]http://dl.iteye.com/upload/attachment/429564/0773cf20-8152-3fbf-b8aa-f437141a83be.jpg[/img]

« »

发表评论

电子邮件地址不会被公开。 必填项已用*标注

昵称 *