eclipse Hibernate Tools插件错误:Fetching children of Database

我遇到这个错误是因为最近安装了Spring Tools Suite插件,生成model类时,遇此问题。经过调查,发现里面的slf4j版本高于1.5.8导致这个问题,并且hibernate tools调用的jar包不是项目中添加的的jar包,而是eclipse自身已安装的jar包。

解决办法:

可以去eclipse目录下找到artifacts.xml,并搜索org.slf4j.api,将version一字不差的改成”1.5.8.v20120130-2120“,重启eclipse即可。


发表评论

邮箱地址不会被公开。 必填项已用*标注

昵称 *