Android Compatibility Package 相容性开发套件下载安装

Java 发表评论

 我们认为 Android 3.0 平板电脑系统在美国时间 2011 年2月22日的正式推出,对于Android 手机应用程式开发者所象征的意涵是:

  过往大家所开发过的 Android 手机应用程式,除了可以在 Android 智慧型手机作业系统之上运行外,也因为 Android 3.0 平板电脑作业系统的向下相容之故,致使这些 Android 手机应用程式亦能跨足到 Android 平板电脑作业系统的新领域之中。

  然而,Android 官方认为这还不够!

  假若,专为 Android 3.0 平板电脑作业系统所开发的应用程式,能够相容于其它Android 智慧型手机作业系统之中,那么 Android 应用程式开发市场的广大疆域才可以真正地被开启。

  但是,问题来了!

  Android 3.0 SDK 有很多专为平板电脑使用者介面所发展出来的 API ,这些新的 API 并没有被定义在目前的 Android 智慧型手机作业系统之中。

  除非,每一位 Android 智慧型手机的用户都有办法下载更新 Android 3.0 SDK 里头的 API 使用,要不然,这些 Android 平板电脑应用程式到了 Android 智慧型手机之上,就只能望机心叹了!

  但是,全面性地更新 Android 智慧型手机作业系统版本,谈何容易!

  这个困境肇因于 Android 的开放性。

  因为,目前全球市售的 Android 智慧型手机从 Android 1.6 、 Android 2.1 、 Android 2.2 、甚至 Android 2.3 ,什么版本的 Android 智慧型手机都有。

  再加上,不同的 Android 智慧型手机硬体业者为了要建立自身的产品差异性之故,似乎常会自行变更其中的系统程式内容。导致 Android 平板电脑应用程式要与 Android 智慧型手机作业系统相容的目标,在短期之内非常难以达成。

  那怎么办呢?

  Android 官方想出了一个好办法!

 

那就是Android Compatibility Package

这里转来一篇关于Android Compatibility Package的介绍,供大家参考学习。

发表评论

邮箱地址不会被公开。 必填项已用*标注

昵称 *