Missing artifact jdk.tools:jdk.tools:jar:1.8


在Eclipse中使用Maven时,发现缺少jdk.tools.1.8.jar,导致编译失败。而这个包是jdk提供的包,按理不应该缺失才对。
原来,Eclipse默认使用的是jre的运行环境,所以找不到jdk的包,解决方法,编辑Eclipse安装目录下面的eclipse.ini,在”-vmargs”前添加下面代码,保存、重启eclipse后Update Project即可。

-vm
<your_jdk_path>\jre\bin\server\jvm.dll

发表评论

邮箱地址不会被公开。 必填项已用*标注

昵称 *