你用的 JDK 版本居然还是1.5!

Java 发表评论

项目开发中,

有时候真是让人无可奈何!

辛苦开发的项目,

在服务器上部署时,

居然跑不起来,查其原因,

居然是 JDK 版本太低!

java -version 一下,

居然是 1.5。。。

是 1.6 。。。

在这个计算机技术以指数级增长的时代,

不要求咱的服务器中软件环境时时保持最新,

但最起码应该在一定时间内更新一次吧。

jdk 1.5 版本,怎么让目前开发的程序能跑起来,

而且官网版本已经到了1.10。。。

在开发中,

常常建议不用最新版本,

因为常常不是很稳定,

而且出现错误,

很难解决,

网上资料也太少,

但程序猿,

都有强迫症,

你懂得 ^^

但也不建议用太老的版本,

毕竟天下之大,

程序猿之众,

项目之多,

老版本很难兼容大多数项目。

所以,

选择一款差不多的版本,

时时关注官网动态,

也要定期更新自己用的版本,

就显得很重要了。

官网地址:http://www.oracle.com/technetwork/java/javase/overview/index.html

版本目录:http://www.oracle.com/technetwork/java/archive-139210.html

发表评论

电子邮件地址不会被公开。 必填项已用*标注

昵称 *